[PATCH] D150241: [SLP][NFC] Rename a couple of variables and replace an if-else with an std::min

Vasileios Porpodas via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue May 9 20:09:46 PDT 2023


vporpo created this revision.
vporpo added reviewers: ABataev, RKSimon.
Herald added a subscriber: hiraditya.
Herald added a project: All.
vporpo requested review of this revision.
Herald added subscribers: llvm-commits, pcwang-thead.
Herald added a project: LLVM.

- Rename `LimitForRegisterSize` to `MaxVFOnly` to make the meaning of the limit less ambiguous
- Rename `OpsWidth` to `ActualVF`, which makes it clear that this is the VF we are using for vectorization.
- Replace the if-else code for the initialization of OpsWidth with an std::min.


Repository:
  rG LLVM Github Monorepo

https://reviews.llvm.org/D150241

Files:
  llvm/include/llvm/Transforms/Vectorize/SLPVectorizer.h
  llvm/lib/Transforms/Vectorize/SLPVectorizer.cpp

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D150241.520890.patch
Type: text/x-patch
Size: 6966 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20230510/e645c885/attachment.bin>


More information about the llvm-commits mailing list