[PATCH] D148196: [SelectionDAG] Rename ADDCARRY/SUBCARRY to UADDO_CARRY/USUBO_CARRY (NFC)
Simon Pilgrim via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Sat Apr 22 04:51:48 PDT 2023
RKSimon added a comment.
SGTM, do you want to get the input from the target specialists that you update the most (ARM/AMDGPU)?
================
Comment at: llvm/lib/Target/SystemZ/SystemZISelLowering.cpp:4003
static bool isSubBorrowChain(SDValue Carry) {
+ while (Carry.getOpcode() == ISD::USUBO_CARRY)
----------------
barannikov88 wrote:
> RKSimon wrote:
> > rename?
> Might make sense, but I'm not sure if the names of these two functions are derived from node names.
>
Only a minor suggestion - it shouldn't derail this patch.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D148196/new/
https://reviews.llvm.org/D148196
More information about the llvm-commits
mailing list