[PATCH] D148698: [NFC] Rename isPointerOffset to getPointerOffsetFrom and move to Value.h
Orlando Cazalet-Hyams via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Wed Apr 19 03:16:25 PDT 2023
Orlando created this revision.
Orlando added reviewers: jmorse, StephenTozer, paulkirth.
Herald added a subscriber: hiraditya.
Herald added a project: All.
Orlando requested review of this revision.
Herald added a project: LLVM.
Herald added a subscriber: llvm-commits.
Linking LibCore failed when building D148536 <https://reviews.llvm.org/D148536> with shared libs enabled (bot <https://lab.llvm.org/buildbot/#/builders/121/builds/29766>).
Make `isPointerOffset` a `Value` method and rename it to `getPointerOffsetFrom`.
https://reviews.llvm.org/D148698
Files:
llvm/include/llvm/Analysis/ValueTracking.h
llvm/include/llvm/IR/Value.h
llvm/lib/Analysis/ValueTracking.cpp
llvm/lib/IR/Value.cpp
llvm/lib/Target/AArch64/AArch64StackTagging.cpp
llvm/lib/Transforms/Scalar/MemCpyOptimizer.cpp
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D148698.514881.patch
Type: text/x-patch
Size: 10003 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20230419/6426dde6/attachment.bin>
More information about the llvm-commits
mailing list