[PATCH] D148196: [SelectionDAG] Rename ADDCARRY/SUBCARRY to UADDO_CARRY/USUBO_CARRY

Sergei Barannikov via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu Apr 13 01:56:39 PDT 2023


barannikov88 marked an inline comment as done.
barannikov88 added inline comments.


================
Comment at: llvm/lib/Target/SystemZ/SystemZISelLowering.cpp:4003
 
 static bool isSubBorrowChain(SDValue Carry) {
+  while (Carry.getOpcode() == ISD::USUBO_CARRY)
----------------
RKSimon wrote:
> rename?
Might make sense, but I'm not sure if the names of these two functions are derived from node names.



Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D148196/new/

https://reviews.llvm.org/D148196



More information about the llvm-commits mailing list