[PATCH] D148196: [SelectionDAG] Rename ADDCARRY/SUBCARRY to UADDO_CARRY/USUBO_CARRY

Simon Pilgrim via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu Apr 13 01:36:07 PDT 2023


RKSimon added inline comments.


================
Comment at: llvm/lib/Target/SystemZ/SystemZISelLowering.cpp:3997
 
 static bool isAddCarryChain(SDValue Carry) {
+  while (Carry.getOpcode() == ISD::UADDO_CARRY)
----------------
rename?


================
Comment at: llvm/lib/Target/SystemZ/SystemZISelLowering.cpp:4003
 
 static bool isSubBorrowChain(SDValue Carry) {
+  while (Carry.getOpcode() == ISD::USUBO_CARRY)
----------------
rename?


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D148196/new/

https://reviews.llvm.org/D148196



More information about the llvm-commits mailing list