[PATCH] D147506: [DebugLine] save one debug line entry for empty prologue
Adrian Prantl via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Wed Apr 12 19:18:41 PDT 2023
aprantl added a comment.
I think this seems reasonable. Dis you run the LLDB test suite against this change?
================
Comment at: llvm/lib/CodeGen/AsmPrinter/DwarfDebug.cpp:2160
unsigned CUID) {
+ std::pair<DebugLoc, bool> PrologEnd = findPrologueEndLoc(&MF);
+
----------------
Are we allowed to use structured bindings? In any case, could you assign this to named variables, the .first and .second make the code harder to read.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D147506/new/
https://reviews.llvm.org/D147506
More information about the llvm-commits
mailing list