[PATCH] D144596: [lld] Support separate native object file path in --thinlto-prefix-replace

Fangrui Song via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Apr 3 19:37:36 PDT 2023


MaskRay accepted this revision as: MaskRay.
MaskRay added inline comments.


================
Comment at: lld/MachO/Driver.cpp:874
+getOldNewOptionsExtra(opt::InputArgList &args, unsigned id) {
+  auto [oldOption, second] = getOldNewOptions(args, id);
+  auto [newOption, extraOption] = second.split(';');
----------------
The original function name `getOldNewOptions` is a misnomer in using "option" instead of other terms like "value". `--thinlto-prefix-replace` is an option. The argument is a colon separated list.

Since below you use `old_dir/etc`, you can use `oldDir`/`newDir`/etc.


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D144596/new/

https://reviews.llvm.org/D144596



More information about the llvm-commits mailing list