[PATCH] D146876: [ThinLTO] Only import for non-prevailing interposable global variables
Shoaib Meenai via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Wed Mar 29 02:07:49 PDT 2023
smeenai added inline comments.
================
Comment at: llvm/include/llvm/Transforms/IPO/FunctionImport.h:161
+ function_ref<bool(GlobalValue::GUID, const GlobalValueSummary *)>
+ isPrevailing,
+ const ModuleSummaryIndex &Index, FunctionImporter::ImportMapTy &ImportList);
----------------
fhahn wrote:
> nit: The naming here is inconsistent with the other arguments; it should probably be `IsPrevailing`.
I thought about that, but for this particular variable, every other place always uses `isPrevailing`. IIRC there was discussion at some point around changing the style guide to lowerCamelCase function-like variables; I guess they were preemptively following that?
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D146876/new/
https://reviews.llvm.org/D146876
More information about the llvm-commits
mailing list