[PATCH] D145873: Move definitions of ArgKind from Intrinsics.h to Intrinsics.td

Craig Topper via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue Mar 14 16:05:44 PDT 2023


craig.topper added inline comments.


================
Comment at: llvm/utils/TableGen/IntrinsicEmitter.cpp:176
+  if (auto RecArgKind = Records.getDef("ArgKind")) {
+    for (auto &Rec : RecArgKind->getValues())
+      OS << "    AK_" << Rec.getName() << " = " << *Rec.getValue() << ",\n";
----------------
`Rec` confused me at first. These aren't Records. I think they are RecordVal? `RV` or `Field` would be a better name.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D145873/new/

https://reviews.llvm.org/D145873



More information about the llvm-commits mailing list