[PATCH] D144944: [GuardWidening] Make sure widened condition operands are available at insertion point

Max Kazantsev via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue Feb 28 00:30:26 PST 2023


mkazantsev added a comment.

I think the naming here is extremely confusing and misleading. Can you pls rename `isAvailableAt` into something that better corresponds to its true semantics in a follow-up patch?



================
Comment at: llvm/lib/Transforms/Scalar/GuardWidening.cpp:555
                 ConstantInt::get(Cond0->getContext(), NewRHSAP);
+            assert(isAvailableAt(LHS, InsertPt) && "must be");
+            makeAvailableAt(LHS, InsertPt);
----------------
Why is that guaranteed?


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D144944/new/

https://reviews.llvm.org/D144944



More information about the llvm-commits mailing list