[PATCH] D144584: [RISCV][NFC] Reuse getDeinterleaveViaVNSRL to lower deinterleave intrinsics

Philip Reames via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Feb 22 13:21:31 PST 2023


reames added inline comments.


================
Comment at: llvm/lib/Target/RISCV/RISCVISelLowering.cpp:2953
                                   const RISCVSubtarget &Subtarget) {
-  // Need to be able to widen the vector.
-  if (VT.getScalarSizeInBits() >= Subtarget.getELEN())
----------------
Personally, I'd leave this duplicated in each caller.  Keeping the helper as an unconditionally successful routine seems worth the very minor code duplication.  


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D144584/new/

https://reviews.llvm.org/D144584



More information about the llvm-commits mailing list