[PATCH] D142405: [CMake] Replace list(FIND) by if(IN_LIST) where index isn't used
Aaron Puchert via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Mon Jan 23 14:34:50 PST 2023
aaronpuchert created this revision.
aaronpuchert added a reviewer: beanz.
Herald added a subscriber: arphaman.
Herald added a project: All.
aaronpuchert requested review of this revision.
Herald added a project: LLVM.
Herald added a subscriber: llvm-commits.
If we don't use the index otherwise, if(IN_LIST) is more readable and
doesn't clutter the local scope with index variables.
This was pointed out by @beanz in D96670 <https://reviews.llvm.org/D96670>.
Repository:
rG LLVM Github Monorepo
https://reviews.llvm.org/D142405
Files:
llvm/cmake/config-ix.cmake
llvm/cmake/modules/AddLLVM.cmake
llvm/cmake/modules/AddSphinxTarget.cmake
llvm/cmake/modules/ChooseMSVCCRT.cmake
llvm/cmake/modules/LLVM-Config.cmake
llvm/cmake/modules/LLVMExternalProjectUtils.cmake
llvm/cmake/modules/LLVMProcessSources.cmake
llvm/cmake/modules/TableGen.cmake
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D142405.491510.patch
Type: text/x-patch
Size: 10259 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20230123/d85037f4/attachment.bin>
More information about the llvm-commits
mailing list