[PATCH] D142370: [SCCPSolver] Move helper functions inside SCCPSolver (NFC).
Florian Hahn via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Mon Jan 23 07:57:27 PST 2023
fhahn created this revision.
fhahn added reviewers: SjoerdMeijer, nikic, spatel, labrinea.
Herald added subscribers: nlopes, snehasish, ormris, StephenFan, hiraditya.
Herald added a project: All.
fhahn requested review of this revision.
Herald added a project: LLVM.
This patch moves a couple of helper functions from the global llvm::
namespace into the SCCPSolver class. This reduces the need for separate
SCCPSolver arguments and also limits the scope of those functions that
have quite generic names.
(The remaining isConstant and isOverdefined should ideally be removed)
Repository:
rG LLVM Github Monorepo
https://reviews.llvm.org/D142370
Files:
llvm/include/llvm/Transforms/Utils/SCCPSolver.h
llvm/lib/Transforms/IPO/SCCP.cpp
llvm/lib/Transforms/Scalar/SCCP.cpp
llvm/lib/Transforms/Utils/SCCPSolver.cpp
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D142370.491383.patch
Type: text/x-patch
Size: 14949 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20230123/c79c336c/attachment-0001.bin>
More information about the llvm-commits
mailing list