[PATCH] D140382: [CodeGen] Add user interface for DetectDeadLanes
Craig Topper via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Wed Jan 4 21:21:31 PST 2023
craig.topper added inline comments.
================
Comment at: llvm/lib/CodeGen/DetectDeadLanes.cpp:441
bool Again = false;
+ if (!NeedSetUndef)
+ return std::make_pair(Changed, Again);
----------------
craig.topper wrote:
> Can we split this function into two functions above and below this point and check this flag in the while loop?
let me rephrase
Can we split this function into two functions above and below this point? Have the while loop in the caller only call the second half when NeedSetUndef is true. The first function can just return void since it doesn't modify anything.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D140382/new/
https://reviews.llvm.org/D140382
More information about the llvm-commits
mailing list