[PATCH] D139316: ValueTracking: Teach isKnownNeverInfinity about rounding intrinsics
Joshua Cranmer via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Tue Dec 20 08:09:18 PST 2022
jcranmer-intel added inline comments.
================
Comment at: llvm/include/llvm/IR/Type.h:188-194
+ /// Returns true if this is a floating-point type with APFloat::DoubleAPFloat
+ /// representation
+ bool isMultiWordFPType() const {
+ return getTypeID() == PPC_FP128TyID;
+ }
+
----------------
IMHO, "unit" is a slightly better name, but I think more important than getting the name right is clarifying what is meant in the documentation comment.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D139316/new/
https://reviews.llvm.org/D139316
More information about the llvm-commits
mailing list