[PATCH] D140068: [NFC] Rename Function::insertBasicBlockAt() to Function::insert().

Vasileios Porpodas via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Dec 14 16:26:16 PST 2022


vporpo created this revision.
vporpo added reviewers: aeubanks, asbirlea.
Herald added subscribers: zzheng, hiraditya.
Herald added a project: All.
vporpo requested review of this revision.
Herald added a project: LLVM.
Herald added a subscriber: llvm-commits.

I think this is a better name because it is what STL uses.


Repository:
  rG LLVM Github Monorepo

https://reviews.llvm.org/D140068

Files:
  llvm/examples/Kaleidoscope/BuildingAJIT/Chapter1/toy.cpp
  llvm/examples/Kaleidoscope/BuildingAJIT/Chapter2/toy.cpp
  llvm/examples/Kaleidoscope/BuildingAJIT/Chapter3/toy.cpp
  llvm/examples/Kaleidoscope/BuildingAJIT/Chapter4/toy.cpp
  llvm/examples/Kaleidoscope/Chapter5/toy.cpp
  llvm/examples/Kaleidoscope/Chapter6/toy.cpp
  llvm/examples/Kaleidoscope/Chapter7/toy.cpp
  llvm/examples/Kaleidoscope/Chapter8/toy.cpp
  llvm/examples/Kaleidoscope/Chapter9/toy.cpp
  llvm/include/llvm/IR/Function.h
  llvm/lib/Frontend/OpenMP/OMPIRBuilder.cpp
  llvm/lib/IR/BasicBlock.cpp
  llvm/lib/IR/Core.cpp
  llvm/lib/Transforms/Utils/BreakCriticalEdges.cpp
  llvm/lib/Transforms/Utils/CloneFunction.cpp
  llvm/lib/Transforms/Utils/CodeExtractor.cpp
  llvm/lib/Transforms/Utils/LoopUnroll.cpp
  llvm/lib/Transforms/Utils/LoopUnrollAndJam.cpp
  llvm/lib/Transforms/Utils/LowerSwitch.cpp
  llvm/unittests/IR/FunctionTest.cpp

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D140068.483028.patch
Type: text/x-patch
Size: 16592 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20221215/cc3cd367/attachment.bin>


More information about the llvm-commits mailing list