[PATCH] D137725: [OpenMP][OMPIRBuilder] Mirgrate getName from clang to OMPIRBuilder
Jan Sjödin via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Wed Nov 23 09:26:04 PST 2022
jsjodin updated this revision to Diff 477533.
jsjodin added a comment.
Make firstSeparator() and separator() return the correct default values when the optional values are not set. This will allow overriding the default, and will avoid inconsistencies in the case IsTargetCodegen is modified in the config. Change name of getName to something more descriptive. Maybe getPlatformSpecificName is better than createPlatformSpecificName, feedback is welcome.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D137725/new/
https://reviews.llvm.org/D137725
Files:
clang/lib/CodeGen/CGOpenMPRuntime.cpp
clang/lib/CodeGen/CGOpenMPRuntime.h
clang/lib/CodeGen/CGOpenMPRuntimeGPU.cpp
llvm/include/llvm/Frontend/OpenMP/OMPIRBuilder.h
llvm/lib/Frontend/OpenMP/OMPIRBuilder.cpp
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D137725.477533.patch
Type: text/x-patch
Size: 7093 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20221123/8cd7424e/attachment.bin>
More information about the llvm-commits
mailing list