[PATCH] D137952: [AMDGPU][GFX11] Refactor VOPD operands handling
Joe Nash via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Mon Nov 14 08:31:06 PST 2022
Joe_Nash added a comment.
This looks like a reasonable refactor. Why does it change the error position?
================
Comment at: llvm/lib/Target/AMDGPU/AsmParser/AMDGPUAsmParser.cpp:8501
+ auto ParsedSrcOperandsNum = InstInfo[CompIdx].getParsedSrcOperandsNum();
+ for (unsigned SrcIdx = 0; SrcIdx < ParsedSrcOperandsNum; ++SrcIdx)
+ addOp(CInfo.getParsedSrcIndex(SrcIdx));
----------------
Can we rename SrcIdx to something like MCSrcIdx? So that there is no confusion with the ParsedSrcIndex returned by getParsedSrcIndex.
================
Comment at: llvm/lib/Target/AMDGPU/Utils/AMDGPUBaseInfo.cpp:525
InstInfo::RegIndices InstInfo::getRegIndices(
unsigned ComponentIdx,
----------------
I think there should be a documentation comment for this function.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D137952/new/
https://reviews.llvm.org/D137952
More information about the llvm-commits
mailing list