[PATCH] D137341: [VectorCombine] widen a load with subvector insert
Sanjay Patel via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Thu Nov 3 08:15:09 PDT 2022
spatel added inline comments.
================
Comment at: llvm/lib/Transforms/Vectorize/VectorCombine.cpp:131
static bool canWidenLoad(LoadInst *Load, const TargetTransformInfo &TTI) {
// Do not widen load if atomic/volatile or under asan/hwasan/memtag/tsan.
----------------
Note: I created this helper function to reduce code duplication. I didn't push that NFC change to main yet though (pending feedback here to do something different).
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D137341/new/
https://reviews.llvm.org/D137341
More information about the llvm-commits
mailing list