[PATCH] D136110: [wasm-ld] Define a `__heap_end` symbol marking the end of allocated memory.

Sam Clegg via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Oct 17 14:35:29 PDT 2022


sbc100 added a comment.

lgtm, with comment.



================
Comment at: lld/wasm/Symbols.h:561
+  // therefore be used as a backing store for brk()/malloc() implementations.
+  static DefinedData *heapEnd;
+
----------------
Can you maybe group these together under single comment?   I started to do that above for  __stack_pointer/__stack_low/__stack_high and I think it makes it easier to read this section of code.   I noticed ELF was doing this in its Symbols.h


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D136110/new/

https://reviews.llvm.org/D136110



More information about the llvm-commits mailing list