[PATCH] D135499: [llvm-ocaml] Revise OCaml opaque pointer bindings to match rest of API

Alan via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Fri Oct 7 16:47:59 PDT 2022


alan added a comment.

Per the discussion on https://discourse.llvm.org/t/i-accidentally-created-a-naming-inconsistency-in-the-ocaml-api/65715, I renamed the `pointer_type_in_context` function I previously added. Because this function takes an address space as an argument, I renamed it to `qualified_pointer_type2` to match the existing `qualified_pointer_type` function, which takes an address space as an argument. I also added another function, `pointer_type2`, which uses the opaque pointer API and does not take an address space as an argument, to correspond with existing function `pointer_type`.

I also changed `as` to `a` in the documentation because `as` is an OCaml keyword and therefore not a valid variable name. (The occurrence of `as` in the documentation comment was colored like a keyword in my editor, so it stood out to me.)


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D135499/new/

https://reviews.llvm.org/D135499



More information about the llvm-commits mailing list