[PATCH] D134373: [Analysis] Introduce getLastCallToStaticBonusApplied (NFC)

David Li via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Fri Sep 23 09:50:09 PDT 2022


davidxl added inline comments.


================
Comment at: llvm/include/llvm/Analysis/InlineCost.h:155
+  /// Get the amount of LastCallToStaticBonus applied.
+  int getLastCallToStaticBonusApplied() const {
+    assert(isVariable() && "Invalid access of InlineCost");
----------------
kazu wrote:
> davidxl wrote:
> > should this include other bonuses added too? In that case, the interface name should change accordingly.
> Maybe not.  At the moment, I am not planning to expose other bonuses applied.
Consider changing the name to be getStaticBonusApplied () to be more flexible. If in the future, the data needs to be fetched selectively, parameters can be added for that.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D134373/new/

https://reviews.llvm.org/D134373



More information about the llvm-commits mailing list