[PATCH] D133688: [RISCV] Lower BUILD_VECTOR to RISCVISD::VID_VL if it is floating-point type.

Han-Kuan Chen via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Sep 12 20:11:41 PDT 2022


HanKuanChen updated this revision to Diff 459636.
HanKuanChen added a comment.

1. Rename vle_vid-vfwcvt.ll to vle_vid-vfcvt.ll.

2. isPosZero() is used to check +0.0. Use !isNegative() instead.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D133688/new/

https://reviews.llvm.org/D133688

Files:
  llvm/lib/Target/RISCV/RISCVISelLowering.cpp
  llvm/test/CodeGen/RISCV/rvv/fixed-vectors-fp-buildvec.ll
  llvm/test/CodeGen/RISCV/rvv/vle_vid-vfcvt.ll

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D133688.459636.patch
Type: text/x-patch
Size: 8882 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20220913/cdd5938f/attachment.bin>


More information about the llvm-commits mailing list