[PATCH] D132603: [SLP][NFC] Refactor SLPVectorizerPass::vectorizeRootInstruction method.

Valeriy Dmitriev via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Aug 24 15:47:38 PDT 2022


vdmitrie added inline comments.


================
Comment at: llvm/include/llvm/Transforms/Vectorize/SLPVectorizer.h:123
+  bool
+  vectorizeRootInstruction(PHINode *P, Value *V, BasicBlock *BB,
+                           slpvectorizer::BoUpSLP &R, TargetTransformInfo *TTI,
----------------
vporpo wrote:
> vdmitrie wrote:
> > vporpo wrote:
> > > Nit: This function does the actual work, so we should probably use different names for this and for the one below. Perhaps `vectorizeRootInstructionImpl` ?
> > To be honest I'm not a big fan of such naming for methods (unless it really necessary).
> > If you do not insist on the change I'd keep both using same name.
> Well, using the same function name is fine as long as they do the exact same thing, but in this case the caller also dealing with the postponed values. Yeah, I prefer more descriptive names too than *Impl, but in this case I can't think of anything better. Anyway, feel free to keep the same name.
Changing the name to vectorizeHorReduction would probably fit better.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D132603/new/

https://reviews.llvm.org/D132603



More information about the llvm-commits mailing list