[PATCH] D130949: [NFC][NewGVN] Remove OpIsSafeForPHIOfOpsHelper()
Alina Sbirlea via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Wed Aug 24 15:06:50 PDT 2022
asbirlea added a comment.
I find it easier to follow what's added to `OpSafeForPHIOfOps` without the helper, so seems like a reasonable change.
================
Comment at: llvm/lib/Transforms/Scalar/NewGVN.cpp:2588
+ if (!isa<Instruction>(I))
+ return true;
+ auto OISIt = OpSafeForPHIOfOps.find(I);
----------------
Shouldn't this be `continue;`?
================
Comment at: llvm/lib/Transforms/Scalar/NewGVN.cpp:2597
+ OpSafeForPHIOfOps.insert({I, true});
+ return true;
+ }
----------------
Same comment (`continue;`)
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D130949/new/
https://reviews.llvm.org/D130949
More information about the llvm-commits
mailing list