[PATCH] D131444: [Matrix] Add tests dot product with varied strides

Florian Hahn via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu Aug 11 00:59:58 PDT 2022


fhahn added inline comments.


================
Comment at: llvm/test/Transforms/LowerMatrixIntrinsics/dot-product.ll:596
+
+define <1 x i32> @intrinsic_column_major_load_dot_product_i32_v8_strided(ptr %lhs_address, ptr %rhs_address) {
+; CHECK-LABEL: @intrinsic_column_major_load_dot_product_i32_v8_strided(
----------------
This is the only real strided test now, right? Here it should be sufficient to use a shorter vector, which doesn't generate as much code which makes the check lines easier to read. Also, could you add a comment explaining what's special about this test?


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D131444/new/

https://reviews.llvm.org/D131444



More information about the llvm-commits mailing list