[PATCH] D131290: [llvm-objdump] Create name for fake sections

James Henderson via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Aug 8 03:37:09 PDT 2022


jhenderson added a comment.

Two thoughts:

1. Have you looked into using `StringTableBuilder` at all? I think you should be able to use that instead of hand-rolling your own code to achieve what looks to be the same thing.
2. I'm not convinced by the naming scheme for the fake section names. Are you following any existing precedent for it? If not, I think we need it to be more obviously different to regular section names, as it doesn't seem unreasonable for people to have custom section names like "load0" for their sections. My immediate thought was something like `PT_LOAD#0` for e.g. the PT_LOAD at index 0.

@MaskRay, any thoughts on the naming scheme?


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D131290/new/

https://reviews.llvm.org/D131290



More information about the llvm-commits mailing list