[PATCH] D130281: [NFC] FunctionSamples::getEntrySamples -> getEntryBBSampleCountEstimate

Hongtao Yu via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu Jul 21 09:36:24 PDT 2022


hoy added a comment.

Thanks for making the change. Agreed that `getEntrySamples ` is confusing when used together with `getHeadSamples`.



================
Comment at: llvm/include/llvm/ProfileData/SampleProf.h:888
+  /// samples (i.e. getHeadSamples()), if non-zero.
+  uint64_t getEntryBBSampleCountEstimate() const {
     if (FunctionSamples::ProfileIsCS && getHeadSamples()) {
----------------
nit: how about just name this `getEntrySamplesEstimate` ? `BB` is somehow implicated in the contexts where the API is used.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D130281/new/

https://reviews.llvm.org/D130281



More information about the llvm-commits mailing list