[PATCH] D125779: [llvm-dva] 04 - Locations and ranges
Paul Robinson via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Fri Jul 1 05:45:34 PDT 2022
probinson added inline comments.
================
Comment at: llvm/lib/DebugInfo/LogicalView/Core/LVLocation.cpp:323
+ //-------------------------------------------------------------------------
+ case 0:
+ Stream << "offset " << int(Operands[0]);
----------------
CarlosAlbertoEnciso wrote:
> psamolysov wrote:
> > Is there any enum in the `dwarf` namespace which is equals to zero? If not it could make sense to use a named constant instead of magic number `0`.
> @probinson How do you feel in creating something like dwarf::DW_OP_null similar to the existing dwarf::DW_TAG_null.
DW_TAG_NULL is meaningful in the sense that a 0 tag indicates no more siblings at this nesting level, in the debug info. But a 0 operator should never appear; are you inserting these yourself for some reason?
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D125779/new/
https://reviews.llvm.org/D125779
More information about the llvm-commits
mailing list