[PATCH] D126254: Add support for decoding base64.
Greg Clayton via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Thu Jun 23 16:14:04 PDT 2022
clayborg added inline comments.
================
Comment at: llvm/include/llvm/Support/Base64.h:61
+ constexpr char Inv = 64;
+ static char DecodeTable[] = {
+ Inv, Inv, Inv, Inv, Inv, Inv, Inv, Inv, // ........
----------------
aprantl wrote:
> Could we rename this to `Base64DecodeTable`? It sits in the top-level llvm namespace after all.
this is a static inside of the decodeBase64 function, so it isn't in the top level llvm namespace.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D126254/new/
https://reviews.llvm.org/D126254
More information about the llvm-commits
mailing list