[PATCH] D128344: [AMDGPU] Add the "is_dynamic_callstack" of amd_kernel_code_t to the kernel descriptor

Matt Arsenault via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Jun 22 11:14:08 PDT 2022


arsenm added inline comments.


================
Comment at: llvm/docs/AMDGPUUsage.rst:4000
                                                          32 mode.
-     463:459 1 bit                                   Reserved, must be 0.
+     459     1 bit   IS_DYNAMIC_CALLSTACK            Indicates if the generated
+                                                     machine code is using a
----------------
Since we are actually re-introducing this and not recycling an existing field, we should take the chance to rename it. The call part of the name is misleading since we can need this in situations that do not have calls. How about just DYNAMIC_STACK_SIZE?


================
Comment at: llvm/include/llvm/Support/AMDHSAKernelDescriptor.h:180-181
   uint32_t compute_pgm_rsrc2;
-  uint16_t kernel_code_properties;
-  uint8_t reserved2[6];
+  uint32_t kernel_code_properties;
+  uint8_t reserved2[4];
 };
----------------
arsenm wrote:
> I thought this was already defined here, which was the reason to set it. I'm not sure it makes sense to add the field if it's not already there
We apparently do need to place this here since rocr doesn't want to inspect metadata


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D128344/new/

https://reviews.llvm.org/D128344



More information about the llvm-commits mailing list