[PATCH] D126403: [RISCV] reorganize getFrameIndexReference to reduce code duplication [nfc]

Philip Reames via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu May 26 09:17:43 PDT 2022


reames marked an inline comment as done.
reames added inline comments.


================
Comment at: llvm/lib/Target/RISCV/RISCVFrameLowering.cpp:794
+    // | scalar local variables   | | <----'
+    // |--------------------------| -- <-- SP
+    //
----------------
frasercrmck wrote:
> StephenFan wrote:
> > Do you think it would be better to mention the BP here?
> Mentioning BP makes sense to me. But then the question may become whether we should mention that if it's BP then there's var-sized objects below it, in case people think SP always equals BP? Maybe I'm overthinking it.
This point is mentioned in the comment during base register selection.  I went ahead and duplicated that here for now.

The comments have a bunch of unhelpful duplication.  I'm planning a separate follow up change (with separate review) to address that.  


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D126403/new/

https://reviews.llvm.org/D126403



More information about the llvm-commits mailing list