[PATCH] D124804: [Object][DX] Parse DXContainer Parts
Jakub Kuderski via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Tue May 24 12:48:17 PDT 2022
kuhar added inline comments.
================
Comment at: llvm/include/llvm/Object/DXContainer.h:39-42
+ // The PartIterator is a wrapper around the iterator for the PartOffsets
+ // member of the DXContainer. It contains a refernce to the container, and the
+ // current iterator value, as well as storage for a parsed part header.
+ class PartIterator {
----------------
kuhar wrote:
> nit: could we pull this class out of `DXContainer`? I think this would make it a bit more readable, especially since we have another level of nesting with the `PartData` struct.
Have you considered this suggestion?
================
Comment at: llvm/lib/Object/DXContainer.cpp:37
+ "Cannot call readInteger on non-integral type.");
+ assert(reinterpret_cast<size_t>(Src) % alignof(T) == 0 &&
+ "Unaligned read of value from buffer!");
----------------
nit: I think `uintptr_t` might be more appropriate
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D124804/new/
https://reviews.llvm.org/D124804
More information about the llvm-commits
mailing list