[PATCH] D126079: [NFC][LLVM] Rename all shouldExpandAtomic*InIR to shouldExpandAtomicInstInIR
James Y Knight via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Fri May 20 12:23:29 PDT 2022
jyknight added a comment.
In D126079#3528275 <https://reviews.llvm.org/D126079#3528275>, @tianshilei1992 wrote:
> I did have one patch locally that only keeps the function `shouldExpandAtomicInstInIR(Instruction *)` and in the body it has something like `if (auto *SI = dyn_cast<StoreInst>(I))`. In terms of readability, IMO it is same as overload. However, of course it can reduce number of APIs. I can use that method, but it looks like the controversy here is readability.
Without seeing the result of that refactoring I can't say for sure, but I can imagine that could be an improvement over the status quo.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D126079/new/
https://reviews.llvm.org/D126079
More information about the llvm-commits
mailing list