[PATCH] D126079: [NFC][LLVM] Rename all shouldExpandAtomic*InIR to shouldExpandAtomicInstInIR

Artem Belevich via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Fri May 20 11:52:15 PDT 2022


tra added a comment.

My original suggestion which resulted in this patch was to generalize the API to just one function accepting `Instruction*` and let the target deal with the details.
For many targets there's a fair amount of duplicated code across the per-instruction variant implementation of `shouldExpandX` and using single call would allow to consolidate the atomic expansion logic in fewer places.

Using overloads, indeed, only makes things more opaque without reducing the API surface.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D126079/new/

https://reviews.llvm.org/D126079



More information about the llvm-commits mailing list