[PATCH] D124218: [LoadStoreVectorizer] Consider if operation is faster than before
Matt Arsenault via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Tue May 17 09:04:30 PDT 2022
arsenm added inline comments.
Herald added a subscriber: kosarev.
================
Comment at: llvm/lib/Transforms/Vectorize/LoadStoreVectorizer.cpp:1081
// If the store is going to be misaligned, don't vectorize it.
- if (accessIsMisaligned(SzInBytes, AS, Alignment)) {
+ unsigned Fast;
+ if (accessIsMisaligned(SzInBytes, AS, Alignment, Fast)) {
----------------
Maybe rename to RelativeCost or something?
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D124218/new/
https://reviews.llvm.org/D124218
More information about the llvm-commits
mailing list