[PATCH] D124733: [AMDGPU][NFC] Make lowerINSERT_VECTOR_ELT() more readable

Matt Arsenault via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Sun May 1 15:25:22 PDT 2022


arsenm added inline comments.


================
Comment at: llvm/lib/Target/AMDGPU/SIISelLowering.cpp:5811-5812
+  //
+  // TODO: However, we can only handle vector size of 64 bits for now.
+  assert(VecSize <= 64);
 
----------------
Don't see the point of this todo. We don't have bit operations > 64 bit so wouldn't want to handle them here


================
Comment at: llvm/lib/Target/AMDGPU/SIISelLowering.cpp:5835
+
+  // Perform (3) above.
+  SDValue BCVec = DAG.getNode(ISD::BITCAST, SL, IntVT, Vec);
----------------
Why refer to another comment instead of just adding the comment here in the first place?


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D124733/new/

https://reviews.llvm.org/D124733



More information about the llvm-commits mailing list