[PATCH] D110972: [DA] Handle mismatching loop levels by updating the numbering scheme
Michael Kruse via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Wed Apr 20 16:09:20 PDT 2022
Meinersbur added inline comments.
================
Comment at: llvm/lib/Analysis/DependenceAnalysis.cpp:752
+ const Instruction *Src, const Instruction *Dst,
+ const SmallVector<Subscript> Pairs) {
const BasicBlock *SrcBlock = Src->getParent();
----------------
congzhe wrote:
> Would it be better to pass `Pairs` by reference?
>
> And rename `Pairs` to `Pair` (since `Pairs` is used as an integer elsewhere)?
Even better: Pass `ArrayRef<Subscript>`
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D110972/new/
https://reviews.llvm.org/D110972
More information about the llvm-commits
mailing list