[PATCH] D123012: [AArch64] Alter mull buildvectors(ext(..)) combine to work on shuffles

Nicholas Guy via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Apr 4 00:43:32 PDT 2022


NickGuy added a comment.

Code looks good to me, but a small nitpick on the function name



================
Comment at: llvm/lib/Target/AArch64/AArch64ISelLowering.cpp:13643
+/// SExt/ZExt rather than the scalar SExt/ZExt
 static SDValue performBuildVectorExtendCombine(SDValue BV, SelectionDAG &DAG) {
   EVT VT = BV.getValueType();
----------------
As this no longer solely operates on BuildVector instructions, should the "Build" part of the function name be removed?


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D123012/new/

https://reviews.llvm.org/D123012



More information about the llvm-commits mailing list