[PATCH] D120818: [VE] Split v512.32 load store into interleaved v256.32 ops
Kazushi Marukawa via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Fri Mar 4 02:10:15 PST 2022
kaz7 added inline comments.
================
Comment at: llvm/lib/Target/VE/VVPISelLowering.cpp:151-153
+SDValue VETargetLowering::splitLoadStore(SDValue Op, VECustomDAG &CDAG) const {
+ auto VVPOC = *getVVPOpcode(Op.getOpcode());
+ assert((VVPOC == VEISD::VVP_LOAD) || (VVPOC == VEISD::VVP_STORE));
----------------
This function is implemented for only PackedLoad and PackedStore, isn't this?
If so, I think `splitPackedLoadStore` is better name for this function. I also think adding an assert to check PackedVector type or something related to packed-load and packed-store if it is possible.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D120818/new/
https://reviews.llvm.org/D120818
More information about the llvm-commits
mailing list