[PATCH] D115873: [LAA] Add remarks for unbounded array access

Sander de Smalen via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Feb 23 05:50:38 PST 2022


sdesmalen accepted this revision.
sdesmalen added inline comments.
This revision is now accepted and ready to land.


================
Comment at: llvm/lib/Analysis/LoopAccessAnalysis.cpp:2106
       auto *SE = PSE->getSE();
-      CanDoRTIfNeeded = Accesses.canCheckPtrAtRT(*PtrRtChecking, SE, TheLoop,
-                                                 SymbolicStrides, true);
+      Value *UncomputablePtr2 = nullptr;
+      CanDoRTIfNeeded = Accesses.canCheckPtrAtRT(
----------------
nit: I'm not really a fan of the name, so personally I would prefer to reuse the old variable, e.g. reset it first:
  UncomputablePtr = nullptr;

and then pass that into canCheckPtrAtRT.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D115873/new/

https://reviews.llvm.org/D115873



More information about the llvm-commits mailing list