[PATCH] D119945: [AMDGPU] Return better Changed status from SIAnnotateControlFlow
Piotr Sobczak via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Wed Feb 16 12:08:38 PST 2022
piotr added inline comments.
================
Comment at: llvm/lib/Target/AMDGPU/SIAnnotateControlFlow.cpp:196
// Erase "Phi" if it is not used any more
+bool SIAnnotateControlFlow::eraseIfUnused(PHINode *Phi) {
----------------
Looks good to me, but for clarity maybe extend the comments with ", return true if a change was made."?
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D119945/new/
https://reviews.llvm.org/D119945
More information about the llvm-commits
mailing list