[PATCH] D119338: [AArch64][SVE] Add structured load/store opcodes to getMemOpInfo
Sander de Smalen via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Wed Feb 9 08:14:24 PST 2022
sdesmalen added inline comments.
================
Comment at: llvm/test/CodeGen/AArch64/ldN-reg-imm-alloca.ll:6
+
+define <vscale x 32 x i8> @ld2b_imm(<vscale x 16 x i1> %pg) #0 {
+; CHECK-LABEL: ld2b_imm:
----------------
Tests that rely on `vscale_range` become more readable if they'd have the `vscale_range` specified directly with the definition. If the test file is long (like this one), the #<some number> make it really obscure what vscale_range it refers to.
I fixed something similar in 11cea7e5ce4d3f6a0d2fac016d503f99c52cdc96
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D119338/new/
https://reviews.llvm.org/D119338
More information about the llvm-commits
mailing list