[PATCH] D118362: [DAGCombine] Extend and refactor combineCarryDiamond()
Simon Pilgrim via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Fri Jan 28 13:10:18 PST 2022
RKSimon added inline comments.
================
Comment at: llvm/lib/CodeGen/SelectionDAG/DAGCombiner.cpp:3079
+ if (Carry1.getNode()->isOperandOf(Carry0.getNode()))
std::swap(Carry0, Carry1);
+
----------------
chfast wrote:
> RKSimon wrote:
> > Do we need this change to get the codegen diff? Or is it just from the getAsCarry? If so we probably want to split the changes for clarity - one as cleanup and the other as improvement?
> The usage of `isOperandOf` is only esthetics. I should commit it separately. Does it need another review?
No, a pre-commit is fine - then rebase this patch.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D118362/new/
https://reviews.llvm.org/D118362
More information about the llvm-commits
mailing list