[PATCH] D117546: [RISCV] Add patterns for vector widening floating-point fused multiply-add instructions

Craig Topper via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue Jan 25 08:15:18 PST 2022


craig.topper added inline comments.


================
Comment at: llvm/lib/Target/RISCV/RISCVInstrInfoVSDPatterns.td:453
+  foreach vti = AllWidenableFloatVectors in {
+    def : Pat<(fma (vti.Wti.Vector (fpext_oneuse (vti.Vti.Vector vti.Vti.RegClass:$rs1))),
+                   (vti.Wti.Vector (fpext_oneuse (vti.Vti.Vector vti.Vti.RegClass:$rs2))),
----------------
frasercrmck wrote:
> This isn't crucial but I wonder if these patterns could be made easier to read if `vti.Wti.Vector` and `vti.Vti.Vector` were `defvar`d into variables. They're really eating up the columns.

We also don’t need vti..Wti.Vector on every fma operand. Once it’s said for any operand or the result, tablegen can infer it for the other operands.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D117546/new/

https://reviews.llvm.org/D117546



More information about the llvm-commits mailing list