[PATCH] D76445: [WIP][RISCV][GlobalISel] Select ALU GPR instructions
Matt Arsenault via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Mon Jan 17 16:02:27 PST 2022
arsenm added inline comments.
Herald added subscribers: alextsao1999, eopXD.
================
Comment at: llvm/lib/Target/RISCV/RISCVInstructionSelector.cpp:97-108
+const TargetRegisterClass *
+RISCVInstructionSelector::getRegClass(Register Reg,
+ const MachineRegisterInfo &MRI) const {
+ const LLT Ty = MRI.getType(Reg);
+ const unsigned Size = Ty.getSizeInBits();
+
+ if (isRegInGprBank(Reg, MRI)) {
----------------
This function name is misleading. Can you restructure to use something more like getRegClassForTypeOnBank (which AArch64 has a FIXME to make a generic TargetRegisterInfo method)
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D76445/new/
https://reviews.llvm.org/D76445
More information about the llvm-commits
mailing list