[PATCH] D117378: [RISCV] [NFC] Add a function to customLegalizeToWOp by Intrinsic

Chenbing.Zheng via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Fri Jan 14 22:41:08 PST 2022


Chenbing.Zheng added inline comments.


================
Comment at: llvm/lib/Target/RISCV/RISCVISelLowering.cpp:5760
 
+static RISCVISD::NodeType getRISCVWOpcodeByIntri(unsigned IntNo) {
+  switch (IntNo) {
----------------
craig.topper wrote:
> I think "Intrinsic" is typically shortened to either "Intrin" or "Intr". I don't recall seeing "Intri" anywhere.
Thanks, I will modify it and pay more attention 


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D117378/new/

https://reviews.llvm.org/D117378



More information about the llvm-commits mailing list