[PATCH] D117363: LLDB Windows x64 buildbot set lit -j8
Galina via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Fri Jan 14 15:01:48 PST 2022
gkistanova added a comment.
> I think they should be set in just one place to make the code more readable.
I was about to suggest the same.
It might be simpler and more straight forward to revert D116972 <https://reviews.llvm.org/D116972> and just explicitly specify the needed `LLVM_LIT_ARGS` in the `extra_cmake_args`.
If you would like to set `-v` and `-j` by default, that could be done by something like this:
defult_lit_args = '-v'
if if jobs:
defult_lit_args += " -j{jobs}".format(jobs=jobs)
CmakeCommand.applyDefaultOptions(cmake_options, [
('-DLLVM_LIT_ARGS=', defult_lit_args),
])
This is not a blocker for this patch, though.
A separate thing. The patch specifies the both `s` and `v`, which kinds of contradict each other, What's the point?
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D117363/new/
https://reviews.llvm.org/D117363
More information about the llvm-commits
mailing list