[PATCH] D114737: [lld][Macho] Include dead-stripped symbols in mapfile

Jez Ng via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Jan 5 01:46:34 PST 2022


int3 added inline comments.


================
Comment at: lld/MachO/MapFile.cpp:45
+// symbols.
+static std::vector<Defined *> getSymbols(bool Live) {
   std::vector<Defined *> v;
----------------
thevinster wrote:
> nit: Variable name should be camel case. Also, I think `dumpLive` or something around that seems to be better fit than just `Live`. 
+1 for camel case. Also, rather than calling `getSymbols` twice, each time iterating over all symbols, it would be more efficient to have the function output two vectors, one for live and one for dead symbols.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D114737/new/

https://reviews.llvm.org/D114737



More information about the llvm-commits mailing list