[PATCH] D115418: [dwarf][NFC] Move expandBundle() to MachO.h

Ellis Hoag via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu Dec 9 11:35:42 PST 2021


ellis created this revision.
Herald added subscribers: cmtice, hiraditya.
Herald added a reviewer: jhenderson.
ellis added reviewers: kyulee, clayborg.
ellis added a project: debug-info.
ellis updated this revision to Diff 393231.
ellis added a comment.
ellis published this revision for review.
Herald added subscribers: llvm-commits, MaskRay.
Herald added a project: LLVM.

Rename function and change behavior slightly.


The function `expandBundle()` is defined both in `llvm-dwarfdump.cpp` and
`llvm-gsymutil.cpp` in the exact same way. Reduce code duplication by
moving this function to the `MachOObjectFile` class.


Repository:
  rG LLVM Github Monorepo

https://reviews.llvm.org/D115418

Files:
  llvm/include/llvm/Object/MachO.h
  llvm/lib/Object/MachOObjectFile.cpp
  llvm/tools/llvm-dwarfdump/llvm-dwarfdump.cpp
  llvm/tools/llvm-gsymutil/llvm-gsymutil.cpp

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D115418.393231.patch
Type: text/x-patch
Size: 7609 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20211209/bfc08de6/attachment.bin>


More information about the llvm-commits mailing list